וורדפרס 2.8.5 בעברית

וורדפרס 2.8.5 בעברית כוללת תיקונים לפרצות אבטחה שהתגלו במהלך העבודה על וורדפרס 2.9. השדרוג מומלץ לכל המשתמשים.

להורדת וורדפרס 2.8.5 בעברית

קישורים ומידע נוסף על וורדפרס 2.8.5 אחרי הקישור

הודעת השחרור הרשמית של WordPress 2.8.5

וורדפרס ואבטחה

בבלוג הרשמי של וורדפרס פורסמה היום הבהרה בנוגע לאבטחה של בלוגים שפועלים תחת וורדפרס, בעקבות פרסומים רבים בימים האחרונים על מתקפה חמורה מהרגיל שמנצלת פרצה בגרסאות מוקדמות של וורדרפס.

זו שורת המפתח מהפוסט, שנכתב על ידי מאט מולנווג, המייסד והמפתח הראשי של וורדפרס:

הדרך היחידה לשמור על הבלוג שלכם בטוח, עכשיו ובעתיד, היא לשדרג לגרסה העדכנית ביותר של וורדפרס.

זה המסר החשוב ביותר שאפשר להעביר על אבטחה של וורדפרס או של כל תוכנה אחרת, ואם אתם מוכנים לעשות רק דבר אחד לשיפור האבטחה של הבלוג שלכם או של כל תוכנה אחרת, עשו את זה. בהמשך להודעה זו, הוספתי כמה הבהרות משל עצמי בנוגע לאבטחה של וורדפרס ואבטחה בכלל בבלוג האישי שלי.

וורדפרס 2.8.4 בעברית

וורדפרס 2.8.4 כוללת תיקון לפרצת אבטחה שאפשרה לתוקף לאפס את הסיסמה של חשבונות משתמש מסויימים בבלוג. עם זאת, פרצה זו לא אפשרה התחברות לבלוג – הסיסמה נשלחת לבעל החשבון, ולא לתוקף.

להורדת וורדפרס 2.8.4

קישורים ומידע נוסף על וורדפרס 2.8.4 אחרי הקישור

Continue reading "וורדפרס 2.8.4 בעברית"

וורדפרס 2.8.3 בעברית

וורדפרס 2.8.3 בעברית כוללת תיקונים נוספים לפרצת האבטחה שהתגלתה בוורדפרס 2.8.1. זהו עדכון אבטחה והשדרוג מומלץ לכל המשתמשים.

להורדת וורדפרס 2.8.3

קישורים ומידע נוסף על וורדפרס 2.8.3 אחרי הקישור

Continue reading "וורדפרס 2.8.3 בעברית"

וורדפרס 2.8.2 בעברית

וורדפרס 2.8.2 בעברית כוללת תיקון לפרצת XSS במערכת התגובות. זהו עדכון אבטחה חשוב ומומלץ לעדכן את כל ההתקנות של וורדפרס בעברית לגרסה זו בהקדם.

להורדת וורדפרס 2.8.2 בעברית

קישורים ומידע נוסף על וורדפרס 2.8.2 אחרי הקישור

Continue reading "וורדפרס 2.8.2 בעברית"

וורדפרס 2.8.1 בעברית

וורדפרס 2.8.1 בעברית כוללת תיקוני אבטחה ותיקוני באגים, וכן מספר שיפורים תאימות וביצועים. גרסה זו פותרת את בעיית כפתור השמירה הנעלם בממשק הניהול.

להורדת וורדפרס 2.8.1 בעברית

קישורים ומידע נוסף על וורדפרס 2.8.1 אחרי הקישור

Continue reading "וורדפרס 2.8.1 בעברית"

וורדפרס 2.8 בעברית

וורדפרס 2.8 תומכת בהתקנת ערכות עיצוב ישירות מתוך וורדפרס, וכוללת ממשק חדש ונוח יותר לניהול ווידג'טים ועורך קוד עם צביעת סינטקס ותיעוד מובנה. מלבד עוד עשרות שיפורים קטנים אך מורגשים, ממשק הניהול של וורדפרס 2.8 מהיר וחלק יותר לשימוש.

להוריד את וורדפרס 2.8 עם תמיכה מלאה בעברית

מידע נוסף על וורדפרס 2.8 אחרי הקישור

Continue reading "וורדפרס 2.8 בעברית"

וורדפרס 2.7.1 בעברית

וורדפרס 2.7.1 היא עדכון תחזוקה לוורדפרס 2.7, וכולללת תיקונים לכ-70 באגים, ביניהם תיקונים לשוניים בתרגום לעברית.

להוריד את וורדפרס 2.7.1

עדכון בנוגע לשדרוג האוטומטי

התקלה בשדרוג האוטומטי נובעת מקצב העדכון של מערכת השדרוג, שמחפשת גרסה חדשה רק מדי 12 שעות ועדיין לא מאפשרת לבצע בדיקה ידנית. וורדפרס 2.7.1 שוחררה בשעה 02:00 לפנות בוקר, ב-12 בפברואר. עם פרסום עדכון זה, העדכון לגרסה העברית כבר יהיה זמין לרוב המשתמשים בוורדפרס 2.7.

משתמשים בגרסאות ישנות יותר יכולים לשדרג לוורדפרס 2.7.1 לפי ההוראות לשדרוג ידני.

הודעה לגבי שדרוג אוטומטי

נכון לעכשיו, לא הצלחתי לעדכן את וורדפרס 2.7 בעברית לוורדפרס 2.7.1 בעברית – העדכון מתעלם מהקבצים של הגרסה העברית ומתקין במקומם את הקבצים המעודכנים מההפצה המקורית באנגלית. כתוצאה מכך, טקסטים בערכת העיצוב הרגילה ("קובריק" עם ההדר הכחול) מופיעים באנגלית במקום בעברית, מספר תיקוני כיווניות קטנים בממשק הניהול נמחקים, ותיקוני התרגום של 2.7.1 לא מותקנים.

בשלב זה, מומלץ לשדרג לוורדפרס 2.7.1 ידנית, לפי ההוראות באתר התיעוד הקהילתי. אפרסם עדכון לפוסט זה ברגע שתתברר הבעיה עם פונקציית השדרוג האוטומטי.

מידע נוסף

הוראות התקנה של וורדפרס

הוראות שדרוג של וורדפרס

הודעת השחרור של WordPress 2.7.1

פרטים נוספים על וורדפרס 2.7 בוויקי

תגובות על וורדפרס 2.7.1 בקבוצת הדיון

וורדפרס 2.7

וורדפרס 2.7 כוללת ממשק ניהול חדש לגמרי, תמיכה בעדכון אוטומטי והתקנה אוטומטית של תוספים, תגובות משורשרות, לוח בקרה מותאם אישית, פוסטים דביקים, ועשרות שיפורים וחידושים נוספים.

להוריד את וורדפרס 2.7

מידע נוסף על וורדפרס 2.7 אחרי הקישור Continue reading "וורדפרס 2.7"

וורדפרס בעברית 2.6.5

וורדפרס בעברית 2.6.5 כוללת תיקונים לפרצת אבטחה ולשלושה באגים. זהו שדרוג מומלץ לכל משתמשי וורדפרס.

להורדת וורדפרס בעברית 2.6.5

העדכון מתקן פרצת XSS שגילה ג'רמיאס ריית', ושמשפיעה רק על שרתים וירטואליים עם כתובת IP ייחודית שמריצים Apache 2.x. להתקנת תיקון האבטחה בלבד, מספיק להעתיק את הקבצים wp-includes/feed.php ו-wp-includes/version.php מוורדפרס 2.6.5 להתקנה קיימת של וורדפרס 2.6.3.

שימו לב שוורדפרס קפצה מגרסה 2.6.3 ישירות לגרסה 2.6.5 כדי למנוע בלבול עם גרסה 2.6.4 מזויפת שיצאה לפני מספר שבועות. לוורדפרס לעולם לא היתה ולעולם לא תהיה גרסה 2.6.4.